Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Info
titleINFO:

For installation we need 2GB RAM. After installation we can use less if needed.

Installation iso could be fetched from http://ftp.nluug.nl/pub/os/illumos/dilos/isos/dilos-1.3.7/dilos-1.3.7.132-amd64.iso

 

Known issues :
At installation your network card will be detected and configured,
but at boot it will not exists as Xen uses the xnf0 interface, 
you need to do the following, replace rtls0 with your network interface

 

Code Block
languagebash
titleFix networking on DilosHVM
  cp /etc/hostname.rtls0 /etc/hostname.xnf0 
  cp /etc/dhcp.rtls0   /etc/dhcp.xnf0
Info
titleKnown Issue error: Failed to start domain diloshvm error: POST operation failed: xend_post: error from xen daemon: (xend.err 'Device 0 (vif) could not be connected. error: Failed to create vnic over bge1 with MAC address XXXXXXXXX)

 Try to find vnic with mac address what you can see in the error message - and remove vnic before vm start using the following command

Code Block
languagebash
titleget conflicting vnic
dladm show-vnic
dladm delete-vnic  <your vnic with the mac address in the error message>
 
virsh shutdown diloshvm
virsh start diloshvm


Code Block
languagebash
titleInstallation command:
virt-install -v --name=dilosHVM --ram=2048 --network bridge \
 --disk path=/dev/zvol/dsk/rpool/xen/dilosHVM,driver=phy --vcpu=2 \
 --cdrom /xen/isos/dilos-1.3.7.132-amd64.iso --vnc